summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKaren Arutyunov <karen@codesynthesis.com>2018-12-01 22:41:01 (GMT)
committerKaren Arutyunov <karen@codesynthesis.com>2018-12-01 22:41:01 (GMT)
commitbf23a7974e861787037288cafcdea1692b96825c (patch)
tree5a1c2a9b2aeceb4104329c4575cfbd42045d7602
parent3bf484996bb2414daa9c30ccf71b703571966dad (diff)
Adapt manifest to wildcard semantics change for build-{include,exclude} values
-rw-r--r--libhello/manifest1
-rw-r--r--libmhello/manifest20
2 files changed, 14 insertions, 7 deletions
diff --git a/libhello/manifest b/libhello/manifest
index d8f92ab..e4460d5 100644
--- a/libhello/manifest
+++ b/libhello/manifest
@@ -13,6 +13,7 @@ url: https://git.build2.org/cgit/hello/libhello
src-url: https://git.build2.org/cgit/hello/libhello/tree/libhello
email: users@build2.org
build-email: builds@build2.org
+#builds: all
depends: * build2 >= 0.8.0-
depends: * bpkg >= 0.8.0-
depends: libformat ^1.0.0
diff --git a/libmhello/manifest b/libmhello/manifest
index 3355d82..792c36e 100644
--- a/libmhello/manifest
+++ b/libmhello/manifest
@@ -13,14 +13,20 @@ url: https://git.build2.org/cgit/hello/libhello
src-url: https://git.build2.org/cgit/hello/libhello/tree/libmhello
email: users@build2.org
build-email: builds@build2.org
-build-exclude: *-msvc_15u0* ; Broken C++ modules support
-build-include: *-msvc_15*
-build-include: *-clang_5*
-build-include: *-clang_6*
-build-exclude: * ; Requires C++ modules support
+#builds: all
+#build-exclude: *-msvc_15u0** ; Broken C++ modules support.
+#build-include: *-msvc_15u**
+#build-include: *-clang_5.**
+#build-include: *-clang_6.**
+#build-exclude: ** ; Requires C++ modules support.
+build-exclude: *-msvc_15u0** ; Broken C++ modules support.
+build-include: *-msvc_15u**
+build-include: *-clang_5.**
+build-include: *-clang_6.**
+build-exclude: ** ; Requires C++ modules support.
requires: c++20
depends: * build2 >= 0.8.0-
depends: * bpkg >= 0.8.0-
depends: libstd-modules
-depends: libmformat [1.0.0 2.0.0-); compatible with libmformat-1.X.Y
-depends: libmprint [1.0.0 2.0.0-); compatible with libmprint-1.X.Y
+depends: libmformat [1.0.0 2.0.0-) ; Compatible with libmformat-1.X.Y.
+depends: libmprint [1.0.0 2.0.0-) ; Compatible with libmprint-1.X.Y.